brew update 또는 brew install 을 할 때에 아래와 같은 오류가 발생하는 경우가 있습니다.

  Error: Cowardly refusing to 'sudo brew update'
 You can use brew with sudo, but only if the brew executable is owned by root.
 However, this is both not recommended and completely unsupported so do so at your own risk.




아래 명령어를 입력한 후 다시 실행하면 됩니다.


  sudo chown root /usr/local/bin/brew 




* 출처: http://stackoverflow.com/questions/19039404/error-cowardly-refusing-to-sudo-brew-install-for-installing-glue-0-3-for-mac


Posted by 고독한 프로그래머

댓글을 달아 주세요


  1. 이전 버전의 XCode를 다운로드한다: https://developer.apple.com/download/
  2. 다운받은 파일을 파인더에서 '패키지 내용 보기'를 누른다.
  3. Contents/Developer/Platforms/ 아래에 플랫폼을 선택한다.
  4. 선택한 플랫폼 아래 /Developer/SDKs/ 밑에 SDK 버전을 선택해서 복사한다.
  5. 현재 설치된 최신 XCode의 똑같은 경로에 복사해 넣는다.


Posted by 고독한 프로그래머
TAG SDK, Xcode

댓글을 달아 주세요